错误:The type javax.servlet.ServletContext cannot be resolved

碰到这个错误,原来是tomcat里的包没有加入Build Path,我把servlet-api.jar加入jdk1.6.0\jre\lib\ext 目录就解决了。
———————

来源:http://blog.csdn.net/cnrefresh/archive/2009/03/10/3977242.aspx
软件包 javax.servlet 不存在

原来这个包在web服务器才有,j2se中并没有,所以导致了错误。
解决方法:
方法(1) 找到%tomcat%\common\lib目录下的servlet-api.jar,把这个路径添加到环境变量classpath当中,就可以了。(这个好像不是很管用,我重装了tomcat之后,再重新配置好像就不行了)
方法(2) 找到%tomcat%\common\lib目录下的servlet-api.jar,把这个jar添加到%java_home%\jdk1.6.0\jre\lib\ext目录下面,不同的jdk版本都一样。




fatkun

239条评论

我已经按照上面所说的做个改正了,怎么还是不对呢?还有别的办法吗?

我已经按照上面所说的做个改正了,怎么还是不对呢?还有别的办法吗?

发表评论

电子邮件地址不会被公开。